PHP Development Environment on RHEL 6.3

PHP Development Environment on RHEL 6.3

0

With a fresh installation you might encounter a dependency problem on installing LAMP stack on RHEL 6. We might be bugged with the below YUM error while installing the required PHP package.

--> Finished Dependency Resolution
Error: Package: php-5.4.28-1.el6.remi.x86_64 (remi)
       Requires: libssl.so.10(libssl.so.10)(64bit)
Error: Package: php-5.4.28-1.el6.remi.x86_64 (remi)
       Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
Error: Package: php-cli-5.4.28-1.el6.remi.x86_64 (remi)
       Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
Error: Package: php-5.4.28-1.el6.remi.x86_64 (remi)
       Requires: libcrypto.so.10(OPENSSL_1.0.1)(64bit)
Error: Package: php-cli-5.4.28-1.el6.remi.x86_64 (remi)
       Requires: libcrypto.so.10(OPENSSL_1.0.1)(64bit)
Error: Package: php-cli-5.4.28-1.el6.remi.x86_64 (remi)
       Requires: libssl.so.10(libssl.so.10)(64bit)
Error: Package: php-5.4.28-1.el6.remi.x86_64 (remi)
       Requires: libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit)
Error: Package: php-cli-5.4.28-1.el6.remi.x86_64 (remi)
       Requires: libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
# Warning! This output is truncated, real output might be longer.

The detail solution were featured on our Coderwall Protips post, click here to read more.

Share This Post: